2.8. PPPoEの設定

注意

UNIVERGE IX-V シリーズでは、PPPoEは利用できません。

PPPoEでは、サブインタフェース(GigaEthernet0.1などの0.0ではないインタフェース)上で、PPPセッションを張り、そのセッション上でIPv4の通信を実現することができます。

../_images/10_pppoe_01.svg

図 2.8.1 インタフェースやデバイスとPPP/PPPoEの関係

../_images/10_pppoe_02.svg

図 2.8.2 PPPoEのシーケンス

../_images/10_pppoe_03.svg

図 2.8.3 ブリッジを使用して、他装置でPPPoEを利用する場合の構成図

../_images/10_pppoe_04.svg

図 2.8.4 セグメントを分けて、他装置でPPPoEを利用する場合の構成図

2.8.1. PPPoEクライアントの設定

PPPoE設定は、インタフェースコンフィグモード(イーサネットのサブインタフェース)で、encapsulation pppoeコマンドを使用して設定します。

以下にPPP登録を含めたPPPoE登録のための設定および基本的な動作を説明します。

  • インタフェースコンフィグモード

    項目

    説明

    encapsulation pppoe

    PPPoEの有効

    pppoe access-concentrator

    アクセスコンセントレータの名称を設定

    pppoe host-uniq-tag

    ホスト特定タグ有効設定

    pppoe service-name

    サービス名の設定

    ppp binding

    インタフェースとプロファイルの関連付け設定

    ip address ipcp

    IPCPで受理した自動割り当てアドレスの利用

  • グローバルコンフィグモード

    項目

    説明

    ppp profile

    プロファイルの設定

  • 表示コマンド

    項目

    説明

    show pppoe status

    PPPoE状態の表示

    show ip address

    IPv4アドレス設定状態表示

    リスト 2.8.1 設定例
    ip route default GigaEthernet1.1
    proxy-dns interface GigaEthernet1.1 priority 100
    !
    ppp profile profile-1
      authentication myname my-router@example.com
      authentication password my-router@example.com my-password
      (PPPoEクライアントでは、authentication request設定は不要です)
    !
    interface GigaEthernet0.0
      ip address 192.168.0.254/24
      proxy-dns ip enable
      no shutdown
    !
    interface GigaEthernet1.1
      encapsulation pppoe
      ppp binding profile-1
      ip address ipcp
      ip napt enable
      no shutdown
    

ブリッジ機能を使用することにより、PPPoEクライアントを接続することが可能です。ブリッジの設定については、ブリッジの節を参照してください。

リスト 2.8.2 設定例
bridge irb enable
no bridge 1 bridge ip
no bridge 1 bridge ipv6
!
ip route default GigaEthernet1.1
proxy-dns ip enable
proxy-dns interface GigaEthernet1.1 priority 100
ppp profile profile-1
  authentication myname my-router@example.com
  authentication password my-router@example.com my-password
!
interface GigaEthernet0.0
  ip address 192.168.0.254/24
  bridge-group 1
  no shutdown
!
interface GigaEthernet1.0
  no ip address
  bridge-group 1
  no shutdown
!
interface GigaEthernet1.1
  encapsulation pppoe
  ppp binding profile-1
  ip address ipcp
  ip napt enable
  no shutdown

2.8.2. PPPoEクライアントの応用

PPPoEクライアント(PPPも同様)による接続では、IPv4などのセッションあるいはBASとの組み合わせが可能です。以下に、接続例を示します。

../_images/10_pppoe_05.svg

図 2.8.5 PPPoE(PPP) 1セッションによる接続例

../_images/10_pppoe_06.svg

図 2.8.6 PPPoE(PPP)複数セッション(単一BAS)による接続例

通常のサービスでは特別な設定は必要ありません。別なインタフェースにそれぞれのセッションの設定を行ってください。

評価環境などで使用する場合は、サービス名を設定することでISPの振り分けを行うことも可能です。設定したサービス名は、Service-Nameタグとして付加されます。

複数セッション使用時は、Host-Uniqタグを使用することで各セッションの振り分けを行います。Host-Uniqタグはpppoe host-uniqコマンドにより有効設定を行いますが、デフォルトで有効になっていますので、複数セッション使用時は設定を削除しないでください。

リスト 2.8.3 設定例
ip route default GigaEthernet1.1
ip route 192.0.2.0/24 GigaEthernet1.2
proxy-dns ip enable
proxy-dns interface GigaEthernet1.1 priority 100
!
ppp profile profile-1
  authentication myname my-router@example1.com
  authentication password my-router@example1.com my-password
!
ppp profile profile-2
  authentication myname my-router@example2.com
  authentication password my-router@example2.com my-password
!
interface GigaEthernet0.0
  ip address 192.168.0.254/24
  no shutdown
!
interface GigaEthernet1.1
  encapsulation pppoe
  pppoe service-name ISP1
  ppp binding profile-1
  ip address ipcp
  ip napt enable
  no shutdown
!
interface GigaEthernet1.2
  encapsulation pppoe
  pppoe service-name ISP2
  ppp binding profile-2
  ip address ipcp
  ip napt enable
  no shutdown
../_images/10_pppoe_07.svg

図 2.8.7 PPPoE(PPP)複数セッション(複数BAS)による接続例

通常のサービスでは特別な設定は必要ありません。2セッション分の設定を行ってください。評価環境などで使用する場合は、アクセスコンセントレータ名を設定することでBASの振り分けを行うことも可能です。設定したアクセスコンセントレータ名が、BASから付与されるAC-Nameと同じ場合に、BASに応答を返します。

リスト 2.8.4 設定例
ip route default GigaEthernet1.1
ip route 192.0.2.0/24 GigaEthernet1.2
proxy-dns ip enable
proxy-dns interface GigaEthernet1.1 priority 100
!
ppp profile profile-1
  authentication myname my-router@example1.com
  authentication password my-router@example1.com my-password
!
ppp profile profile-2
  authentication myname my-router@example2.com
  authentication password my-router@example2.com my-password
!
interface GigaEthernet0.0
  ip address 192.168.0.254/24
  no shutdown
!
interface GigaEthernet1.1
  encapsulation pppoe
  pppoe access-concentrator BAS1
  ppp binding profile-1
  ip address ipcp
  ip napt enable
  no shutdown
!
interface GigaEthernet1.2
  encapsulation pppoe
  pppoe access-concentrator BAS2
  ppp binding profile-2
  ip address ipcp
  ip napt enable
  no shutdown