2. 基本設定

2.1. 初期設定

初期状態から利用開始する設定例です。
初期ユーザー登録モードにログイン後管理者レベルのユーザーアカウントを作成し、作成したユーザーアカウントで再ログインする必要があります。
詳しい手順は『取扱説明書』をご参照ください。
../_images/2.1.png

設定

本装置の設定

Router login: admin
Password: admin

NEC IX-R Series IX-R2530 Software, Version 1.1.18, RELEASE SOFTWARE
Compiled Wed 27 Sep 2023 02:14:55 PM JST
Copyright (c) NEC Corporation 2023. All rights reserved.

Router(init)# username test-user password plain test-pass administrator
% Password strength estimation: score 1(poor).
% User 'test-user' has been added.
Router(init)# exit


NEC IX-R Series IX-R2530 Software, Version 1.1.18, RELEASE SOFTWARE

Router login: test-user
Password: test-pass
Last login: Mon Nov 13 05:18:12 JST 2023 on ttyS0

NEC IX-R Series IX-R2530 Software, Version 1.1.18, RELEASE SOFTWARE
Compiled Wed 27 Sep 2023 02:14:55 PM JST
Copyright (c) NEC Corporation 2023. All rights reserved.

Router#

解説

Router login: admin
Password: admin

初回ログイン専用のユーザー名admin、パスワードadminでログインします。

username test-user password plain test-pass administrator
ユーザーアカウント(ユーザー名 test-user 、パスワード test-pass )をアドミニストレーター権限(管理者レベル)で設定します。
任意のユーザー名とパスワードを設定してください。
exit

初期ユーザー登録モードからログアウトします。

Router login: test-user
Password: test-pass

任意に設定したユーザー名とパスワードでログインします。

2.2. ユーザーアカウントの設定

ユーザーアカウントの設定例です。

../_images/2.1.png

設定

本装置の設定

Router(config)# username test-user2 password plain test-pass2 operator
% Password strength estimation: score score 2(normal).
% User 'test-user2' has been added.

解説

username test-user2 password plain test-pass2 operator
ユーザーアカウント(ユーザー名 test-user2 、パスワード test-pass2 )を オペレーター 権限で設定します。
任意のユーザー名とパスワードを設定してください。

2.3. ホスト名の設定

ホスト名の設定例です。

../_images/2.1.png

設定

本装置の設定

Router# configure
Router(config)# hostname IX-R2530
IX-R2530(config)#

解説

hostname IX-R2530

ホスト名 IX-R2530 を設定します。

2.4. ログ取得設定

ログ取得の設定例です。

../_images/2.1.png

設定

本装置の設定

Router# configure
Router(config)# syslog enable
Router(config)# syslog function all warn

解説

syslog enable
syslog function all warn

ログ取得(取得する機能 all 、取得レベル warn )の設定です。

2.5. NetMeister設定

NetMeisterクライアント機能を利用する場合の設定例です。
グループIDとグループパスワードは、以下の内容でNetMeisterに登録済みとします。
../_images/2.5.1.png ../_images/2.1.png

設定

本装置の設定

Router# configure
Router(config)# hostname IX-R2530
IX-R2530(config)# nm ip enable
IX-R2530(config)# nm account sample-gr password plain sample-pw
IX-R2530(config)# nm sitename tokyo

解説

hostname IX-R2530
ホスト名 IX-R2530 を設定します。
ホスト名は、NetMeister上で装置名として表示されます。
NetMeisterダイナミックDNSサービスのドメインの一部となります。
nm ip enable

NetMeisterクライアント機能を有効化します。

nm account sample-gr password plain sample-pw

NetMeisterで登録したグループID sample-gr とパスワード sample-pw を設定します。

nm sitename tokyo
NetMeisterで登録する拠点ID tokyo を設定します。
本設定を省略した場合、ホスト名が拠点IDとして設定されます。

2.6. DHCPサーバーを使用する

DHCPサーバーの設定例です。

../_images/2.6.png

設定

本装置の設定

Router# configure
Router(config)# ip dhcp profile dhcp-prof
Router(config-dhcp-dhcp-prof)# dns-server 192.168.0.254
Router(config-dhcp-dhcp-prof)# exit
Router(config)# interface GigaEthernet2.0
Router(config-GigaEthernet2.0)# ip address 192.168.0.254/24
Router(config-GigaEthernet2.0)# ip dhcp enable
Router(config-GigaEthernet2.0)# ip dhcp binding dhcp-prof
Router(config-GigaEthernet2.0)# proxy-dns ip enable
Router(config-GigaEthernet2.0)# no shutdown
Router(config-GigaEthernet2.0)# exit
Router(config)#

解説

ip dhcp profile dhcp-prof
  dns-server 192.168.0.254
ip dhcp profileコマンドでDHCPコンフィグモードに移行します。
またDHCPサーバー機能のプロファイル名を dhcp-prof と定義します。
DCHPプロファイル dhcp-prof にDNSサーバーのIPアドレス 192.168.0.254 を登録します。
プロキシDNS機能を使用するため、端末に通知するDNSサーバのIPアドレスは、GE2.0 のIPアドレスとなります。
interface GigaEthernet2.0
  ip dhcp enable
  ip dhcp binding dhcp-prof
  proxy-dns ip enable
DHCP機能の有効化とDHCPプロファイルの関連付けを行います。
プロキシDNS機能を使用する場合、プロキシDNS機能の有効化も行います。
interface GigaEthernet2.0
  ip address 192.168.0.254/24
  no shutdown

IPアドレスの設定とインタフェース有効化設定です。

2.7. SSHサーバーを使用する

SSHサーバーの設定例です。

../_images/2.7.png

設定

本装置の設定

Router# configure
Router(config)# ip access-list ssh-list permit ip src 192.168.0.0/24 dest 192.168.0.254/32
Router(config)# ssh-server ip access-list ssh-list
Router(config)# interface GigaEthernet2.0
Router(config-GigaEthernet2.0)# ip address 192.168.0.254/24
Router(config-GigaEthernet2.0)# ssh-server ip enable
Router(config-GigaEthernet2.0)# no shutdown
Router(config-GigaEthernet2.0)# exit
Router(config)#

解説

ip access-list ssh-list permit ip src 192.168.0.0/24 dest 192.168.0.254/32
ssh-server ip access-list ssh-list

SSH接続用のアクセス制限設定です。

interface GigaEthernet2.0
  ssh-server ip enable

SSHサーバー機能を有効化します。

2.8. Webコンソールを使用する

Webコンソールを有効化する設定例です。

../_images/2.8.png

設定

本装置の設定

Router# configure
Router(config)# ip access-list http-list permit ip src 192.168.0.0/24 dest 192.168.0.254/32
Router(config)# http-server ip access-list http-list
Router(config)# interface GigaEthernet2.0
Router(config-GigaEthernet2.0)# ip address 192.168.0.254/24
Router(config-GigaEthernet2.0)# http-server ip enable
Router(config-GigaEthernet2.0)# no shutdown
Router(config-GigaEthernet2.0)# exit
Router(config)#

解説

ip access-list http-list permit ip src 192.168.0.0/24 dest 192.168.0.254/32
http-server ip access-list http-list

Webコンソール接続用のアクセス制限設定です。

interface GigaEthernet2.0
  http-server ip enable

Webコンソール機能(HTTPサーバー機能)を有効化します。

2.9. タグVLANを使用する

タグVLANの設定例です。
タグVLANの設定は、サブインタフェース(GE2の場合、GE2.1~GE2.32)に対して行います。
../_images/2.9.png

設定

本装置の設定

Router# configure
Router(config)# interface GigaEthernet2.1
Router(config-GigaEthernet2.1)# encapsulation dot1q 10
Router(config-GigaEthernet2.1)# ip address 192.168.0.254/24
Router(config-GigaEthernet2.1)# no shutdown
Router(config-GigaEthernet2.1)# exit
Router(config)# interface GigaEthernet2.2
Router(config-GigaEthernet2.2)# encapsulation dot1q 20
Router(config-GigaEthernet2.2)# ip address 192.168.1.254/24
Router(config-GigaEthernet2.2)# no shutdown
Router(config-GigaEthernet2.2)# exit
Router(config)#

解説

interface GigaEthernet2.1
  encapsulation dot1q 10
サブインタフェース GE2.1 でタグVLAN機能を有効化します。
タグVLAN ID: 10 を設定します。

2.10. ポートVLANを使用する

ポートVLANの設定例です。

../_images/2.10.png

設定

Router# configure
Router(config)# device GigaEthernet2
Router(config-GigaEthernet2)# vlan-group 1 port 1 2
Router(config-GigaEthernet2)# vlan-group 2 port 3 4
Router(config-GigaEthernet2)# exit
Router(config)# interface GigaEthernet2:1.0
Router(config-GigaEthernet2:1.0)# ip address 192.168.0.254/24
Router(config-GigaEthernet2:1.0)# no shutdown
Router(config-GigaEthernet2:1.0)# exit
Router(config)# interface GigaEthernet2:2.0
Router(config-GigaEthernet2:2.0)# ip address 192.168.1.254/24
Router(config-GigaEthernet2:2.0)# no shutdown
Router(config-GigaEthernet2:2.0)# exit
Router(config)#

解説

device GigaEthernet2
  vlan-group 1 port 1 2
  vlan-group 2 port 3 4

SW-HUBポート: 1~2 をポートVLANグループ 1 に、SW-HUBポート: 3~4 をポートVLANグループ 2 に設定します。

interface GigaEthernet2:1.0
ポートVLANグループ 1 の基本インタフェースモードに移行するコマンドです。
タグVLANやPPPoE接続と併用する場合は、サブインタフェースを指定します。