2.1.8. アグレッシブモードでIX、WA間をIPsecで接続する(コマンド設定)

  • 概要

拠点側の対応機種は、WA1511/WA1512/WA2611-AP/WA2611E-AP/WA2612-AP/WA2511E です。
販売終了機種はこちら→→→ 販売終了機種

本社側はIX2106を使用します。
本事例は、拠点-本社間をIPsecでセキュアな接続を行う構成です。
本社ネットワークは光回線、拠点ネットワークはモバイル回線を利用します。
光回線のPPPoEユーザ名、PPPoEパスワードは事前にご契約された通信事業者にご確認ください。
SIMのAPN、ユーザ名、パスワードは事前にご契約された通信事業者にご確認ください。
  • ネットワーク構成図

img100

  • WA1512 サンプルコンフィグ

設定項目

コンフィグ

ホスト名の設定

hostname WA1512

ログインユーザ名、
パスワードの設定

username (ログインユーザ名) password plain (ログインパスワード) administrator

Web-GUIログインユーザ名、
パスワードの設定
http-username (Web-GUIログインユーザ名) password plain (Web-GUIログインパスワード) administrator
DHCPサーバの設定
ip dhcp-server enable
ip dhcp-server profile default
default-gateway auto
dns-server auto
subnet-mask auto

LANインタフェースの設定

interface GigaEthernet1.0
ip address 192.168.2.200/24
ip dhcp-server binding default
no shutdown

WANインタフェースの設定

interface MobileEthernet0.0
ip address dhcp
ip tcp adjust-mss auto
ip napt enable
ip napt reserve icmp
ip napt reserve udp 500
ip napt reserve esp
ip napt reserve udp 4500
mobile id IP (APN)
mobile username (ユーザ名)
mobile password plain (パスワード)
auto-connect
no shutdown

ループバックアドレスの設定

interface Loopback0.0
ip address 127.0.0.1/8
no shutdown

IPsecインターフェースの設定

interface IPsec0
ip address unnumbered
ip tcp adjust-mss auto
ipsec map ipsecprof1
no shutdown

ルーティングの設定

ip route 192.168.1.0/24 IPsec0
ip route default MobileEthernet0.0

DNSプロキシの設定

proxy-dns ip enable
proxy-dns server default MobileEthernet0.0 dhcp

IKEプロポーザルの設定

ike proposal ikeprop1
encryption-algorithm aes256-cbc
authentication-algorithm hmac-sha2-256
lifetime 28800

IKEポリシーの設定

ike policy ikepol1
mode aggressive
dpd-keepalive enable ph1 20 3
local-id key-id (key-id)
proposal ikeprop1
pre-shared-key plain (事前共有鍵)
nat-traversal enable keepalive 20

IPsecプロポーザルの設定

ipsec proposal ipsecprop1
protocol esp enc-algo aes256-cbc auth-algo hmac-sha2-256
lifetime 28800

IPsecポリシーの設定

ipsec policy ipsecpol1
local-id 192.168.2.0/24
remote-id 192.168.1.0/24
rekey enable always
proposal ipsecprop1

IPsecプロファイルの設定

ipsec profile ipsecprof1
mode tunnel
ipsec policy ipsecpol1
ike policy ikepol1
source MobileEthernet0.0
peer ix2106.example.nmddns.jp ※対向ルータ(IX2106)のpeer FQDNを設定

Webサーバの設定

https-server ip enable
https-server ip permit 192.168.2.0/24
https-server ip redirect enable

VPN LEDの設定

led vpn ipsec

  • IX2106 サンプルコンフィグ

設定項目

コンフィグ

ホスト名の設定

hostname IX2106

ログインユーザ名、
パスワードの設定

username (ログイン名) password plain (ログインパスワード) administrator

UFSキャッシュの有効化

ip ufs-cache enable

ルーティングの設定

ip route default GigaEthernet0.1
ip route 192.168.2.0/24 Tunnel0.0

DHCPサーバの有効化

ip dhcp enable

IPsecアクセスリストの設定

ip access-list sec-list permit ip src any dest any

IKEプロポーザルの設定

ike proposal ikeprop encryption aes-256 hash sha2-256

IKEポリシーの設定

ike policy ike-policy peer any key (事前共有鍵) mode aggressive ikeprop

IKEの設定

ike remote-id ike-policy keyid (key-id)

NAT Traversalの設定

ike nat-traversal policy ike-policy

IPsecポリシーの設定

ipsec autokey-proposal secprop esp-aes-256 esp-sha2-256
ipsec dynamic-map ipsec-policy sec-list secprop ike ike-policy

IKEフェーズ2の設定

ipsec local-id ipsec-policy 192.168.1.0/24
ipsec remote-id ipsec-policy 192.168.2.0/24

Webサーバの設定

http-server ip access-list web-http-acl
http-server ip enable

NetMeisterの設定

nm ip enable
nm account (グループID) password plain (パスワード)
nm sitename (サイト名)

PPPoEプロファイルの設定

ppp profile ppp_profile
authentication myname (PPPoEユーザ名)
authentication password (PPPoEユーザ名) (PPPoEパスワード)

DHCPプロファイルの設定

ip dhcp profile default
assignable-range 192.168.1.10 192.168.1.99
default-gateway 192.168.1.254
dns-server 192.168.1.254

LANインターフェースの設定

interface GigaEthernet1.0
ip address 192.168.1.254/24
ip dhcp binding default
no shutdown

DNSプロキシの設定

proxy-dns ip enable
proxy-dns interface GigaEthernet0.1 priority 254

PPPoEインターフェースの設定

interface GigaEthernet0.1
encapsulation pppoe
auto-connect
ppp binding ppp_profile
ip address ipcp
ip tcp adjust-mss auto
ip napt enable
ip napt static GigaEthernet0.1 udp 500
ip napt static GigaEthernet0.1 50
ip napt static GigaEthernet0.1 udp 4500
no shutdown

IPsecインターフェースの設定

interface Tunnel0.0
tunnel mode ipsec
ip unnumbered GigaEthernet1.0
ip tcp adjust-mss auto
ipsec policy tunnel ipsec-policy
no shutdown
  • サンプルコンフィグのダウンロード

WA1512のサンプルコンフィグのダウンロードはこちら サンプルコンフィグ.
IX2106のサンプルコンフィグのダウンロードはこちら サンプルコンフィグ.
  • コンフィグの適用方法

コンフィグの適用方法はこちら→ CLIによるコンフィグの適用方法

  • 動作確認済みSIM

動作確認済みのSIMはこちら

注意

本事例は、設定例を示したものであり、動作を保証するものではありません。
ご利用いただく場合には、検証の上ご利用ください。