2.2.2. 固定アドレス間をL2TPv3 over IPsecで接続する(複数拠点、コマンド設定)

  • 概要

本社側の対応機種は、WA1510/WA1511/WA1512/WA2610-AP/WA2611-AP/WA2611E-AP/WA2612-AP/WA2511E です。
拠点側の対応機種は、WA1511/WA1512/WA2611-AP/WA2611E-AP/WA2612-AP/WA2511E です。
販売終了機種はこちら→→→ 販売終了機種
本事例は、本社、拠点(複数拠点)が同一サブネットの場合に、L2TPv3 over IPsecでセキュアな接続を行う構成です。
本社ネットワークは光回線、拠点ネットワークはモバイル回線を利用します。

光回線のPPPoEユーザ名、PPPoEパスワードは事前にご契約された通信事業者にご確認ください。
SIMのAPN、ユーザ名、パスワードは事前にご契約された通信事業者にご確認ください。
  • ネットワーク構成図

img100

  • WA1510 サンプルコンフィグ

設定項目

コンフィグ

ホスト名の設定

hostname wa1510

ログインユーザ名、
ログインパスワードの設定

username (ログインユーザ名) password plain (ログインパスワード) administrator

Web-GUIログイン名、
ログインパスワードの設定

http-username (Web-GUIログイン名) password plain (Web-GUIログインパスワード) administrator

IPsecアクセスリストの設定

ip access-list sec-list permit ip src any dest any

ブリッジの有効化

bridge ieee enable

DHCPサーバの設定

ip dhcp-server enable
ip dhcp-server profile default
assignable-range 192.168.1.10 50
default-gateway auto
dns-server auto
subnet-mask auto

PPPoEプロファイルの設定

ppp profile pppoeprof
authentication username (PPPoEユーザ名)
authentication password plain (PPPoEパスワード)

WANインタフェースの設定

interface GigaEthernet0.0
no ip address
encapsulation PPPoE0
no shutdown

LANインターフェースの設定

interface GigaEthernet1.0
ip address 192.168.1.100/24
bridge ieee 1
ip dhcp-server binding default
no shutdown

L2TPv3インターフェースの設定(拠点1)

interface L2TP0
l2tp encapsulation l2tpv3
l2tp source Loopback0.0
l2tp peer 10.0.0.2
bridge ieee 1
no shutdown

L2TPv3インターフェースの設定(拠点2)

interface L2TP1
l2tp encapsulation l2tpv3
l2tp source Loopback0.0
l2tp peer 10.0.0.3
bridge ieee 1
no shutdown

ループバックインターフェースの設定

interface Loopback0.0
ip address 10.0.0.1/32
no shutdown

WANインターフェースの設定

interface PPPoE0
ip address ipcp
ip tcp adjust-mss auto
ppp profile pppoeprof
auto-connect
ip napt enable
ip napt reserve icmp
ip napt reserve esp
ip napt reserve udp 500
ip napt reserve udp 4500
no shutdown

IPsecインターフェースの設定(拠点1)

interface IPsec0
ip address unnumbered
ipsec map ipsecprof1
ip tcp adjust-mss auto
no shutdown

IPsecインターフェースの設定(拠点2)

interface IPsec1
ip address unnumbered
ipsec map ipsecprof2
ip tcp adjust-mss auto
no shutdown

ルーティングの設定

ip route 10.0.0.2/32 IPsec0
ip route 10.0.0.3/32 IPsec1
ip route default PPPoE0

DNSプロキシの設定

proxy-dns ip enable
proxy-dns server default PPPoE0 ipcp

IKEプロポーザルの設定(拠点1)

ike proposal ikeprop
encryption-algorithm aes256-cbc
authentication-algorithm hmac-sha2-256

IKEポリシーの設定(拠点1)

ike policy ikepol1
mode main
dpd-keepalive enable ph1 20 3
proposal ikeprop
pre-shared-key plain (事前共有鍵)

IPsecプロポーザルの設定(拠点1)

ipsec proposal ipsecprop
protocol esp enc-algo aes256-cbc auth-algo hmac-sha2-256
lifetime 28800

IPsecポリシーの設定(拠点1)

ipsec policy ipsecpol
match sec-list
rekey enable always
proposal ipsecprop

IPsecプロファイルの設定(拠点1)

ipsec profile ipsecprof1
mode tunnel
ipsec policy ipsecpol
ike policy ikepol1
source PPPoE0
peer :200.200.200.200 ※200.200.200.200は実網のpeerアドレスを設定

IKEプロポーザルの設定(拠点2)

ike proposal ikeprop2
encryption-algorithm aes256-cbc
authentication-algorithm hmac-sha2-256

IKEポリシーの設定(拠点2)

ike policy ikepol2
mode main
dpd-keepalive enable ph1 20 3
proposal ikeprop2
pre-shared-key plain (事前共有鍵)

IPsecプロポーザルの設定(拠点2)

ipsec proposal ipsecprop2
protocol esp enc-algo aes256-cbc auth-algo hmac-sha2-256
lifetime 28800

IPsecポリシーの設定(拠点2)

ipsec policy ipsecpol2
match sec-list
rekey enable always
proposal ipsecprop2

IPsecプロファイルの設定(拠点2)

ipsec profile ipsecprof2
mode tunnel
ipsec policy ipsecpol2
ike policy ikepol2
source PPPoE0
peer :200.200.200.201 ※200.200.200.201は実網のpeerアドレスを設定
  • WA1512-1 サンプルコンフィグ

設定項目

コンフィグ

ホスト名の設定

hostname wa1512-1

ログインユーザ名、
ログインパスワードの設定

username (ログインユーザ名) password plain (ログインパスワード) administrator

Web-GUIログイン名、
ログインパスワードの設定

http-username (Web-GUIログイン名) password plain (Web-GUIログインパスワード) administrator

IPsecアクセスリストの設定

ip access-list sec-list permit ip src any dest any

ブリッジの有効化

bridge ieee enable

LANインターフェースの設定

interface GigaEthernet1.0
ip address 192.168.1.200/24
bridge ieee 1
no shutdown

L2TPv3インターフェースの設定

interface L2TP0
l2tp encapsulation l2tpv3
l2tp source Loopback0.0
l2tp peer 10.0.0.1
bridge ieee 1
no shutdown

ループバックインターフェースの設定

interface Loopback0.0
ip address 10.0.0.2/32
no shutdown

WANインターフェースの設定

interface MobileEthernet0.0
ip address dhcp
ip napt enable
ip napt reserve icmp
ip napt reserve esp
ip napt reserve udp 500
ip napt reserve udp 4500
mobile id IP (APN)
mobile username (ユーザ名)
mobile password plain (パスワード)
auto-connect
no shutdown

IPsecインターフェースの設定

interface IPsec0
ip address unnumbered
ipsec map ipsecprof1
ip tcp adjust-mss auto
no shutdown

ルーティングの設定

ip route 10.0.0.1/32 IPsec0
ip route default MobileEthernet0.0

DNSプロキシの設定

proxy-dns ip enable
proxy-dns server default MobileEthernet0.0 dhcp

IKEプロポーザルの設定

ike proposal ikeprop1
encryption-algorithm aes256-cbc
authentication-algorithm hmac-sha2-256

IKEポリシーの設定

ike policy ikepol1
mode main
dpd-keepalive enable ph1 20 3
proposal ikeprop1
pre-shared-key plain (事前共有鍵)

IPsecプロポーザルの設定

ipsec proposal ipsecprop1
protocol esp enc-algo aes256-cbc auth-algo hmac-sha2-256
lifetime 28800

IPsecポリシーの設定

ipsec policy ipsecpol1
match sec-list
rekey enable always
proposal ipsecprop1

IPsecプロファイルの作成

ipsec profile ipsecprof1
mode tunnel
ipsec policy ipsecpol1
ike policy ikepol1
source MobileEthernet0.0
peer 100.100.100.100 ※100.100.100.100は実網のpeerアドレスを設定
  • WA1512-2 サンプルコンフィグ

設定項目

コンフィグ

ホスト名の設定

hostname wa1512-2

ログインユーザ名、
ログインパスワードの設定

username (ログインユーザ名) password plain (ログインパスワード) administrator

Web-GUIログイン名、
ログインパスワードの設定

http-username (Web-GUIログイン名) password plain (Web-GUIログインパスワード) administrator

IPsecアクセスリストの設定

ip access-list sec-list permit ip src any dest any

ブリッジの有効化

bridge ieee enable

LANインターフェースの設定

interface GigaEthernet1.0
ip address 192.168.1.201/24
bridge ieee 1
no shutdown

L2TPv3インターフェースの設定

interface L2TP0
l2tp encapsulation l2tpv3
l2tp source Loopback0.0
l2tp peer 10.0.0.1
bridge ieee 1
no shutdown

ループバックインターフェースの設定

interface Loopback0.0
ip address 10.0.0.3/32
no shutdown

WANインターフェースの設定

interface MobileEthernet0.0
ip address dhcp
ip napt enable
ip napt reserve icmp
ip napt reserve esp
ip napt reserve udp 500
ip napt reserve udp 4500
mobile id IP (APN)
mobile username (ユーザ名)
mobile password plain (パスワード)
auto-connect
no shutdown

IPsecインターフェースの設定

interface IPsec0
ip address unnumbered
ipsec map ipsecprof1
ip tcp adjust-mss auto
no shutdown

ルーティングの設定

ip route 10.0.0.1/32 IPsec0
ip route default MobileEthernet0.0

DNSプロキシの設定

proxy-dns ip enable
proxy-dns server default MobileEthernet0.0 dhcp

IKEプロポーザルの設定

ike proposal ikeprop1
encryption-algorithm aes256-cbc
authentication-algorithm hmac-sha2-256

IKEポリシーの設定

ike policy ikepol1
mode main
dpd-keepalive enable ph1 20 3
proposal ikeprop1
pre-shared-key plain (事前共有鍵)

IPsecプロポーザルの設定

ipsec proposal ipsecprop1
protocol esp enc-algo aes256-cbc auth-algo hmac-sha2-256
lifetime 28800

IPsecポリシーの設定

ipsec policy ipsecpol1
match sec-list
rekey enable always
proposal ipsecprop1

IPsecプロファイルの作成

ipsec profile ipsecprof1
mode tunnel
ipsec policy ipsecpol1
ike policy ikepol1
source MobileEthernet0.0
peer 100.100.100.100 ※100.100.100.100は実網のpeerアドレスを設定
  • サンプルコンフィグのダウンロード

WA1510のサンプルコンフィグのダウンロードはこちら サンプルコンフィグ.
WA1512-1のサンプルコンフィグのダウンロードはこちら サンプルコンフィグ.
WA1512-2のサンプルコンフィグのダウンロードはこちら サンプルコンフィグ.
  • コンフィグの適用方法

コンフィグの適用方法はこちら→ CLIによるコンフィグの適用方法

  • 動作確認済みSIM

動作確認済みのSIMはこちら

注意

本事例は、設定例を示したものであり、動作を保証するものではありません。
ご利用いただく場合には、検証の上ご利用ください。